Back to overview
Downtime

Service Impact due to CrowdStrike update

Jul 19 at 08:55am CDT
Affected services
claimsbridge.net Web Application
ftp.claimsbridge.net FTP Site
claimsbridge.com Provider Search

Resolved
Jul 19 at 10:47am CDT

All services restored.

Created
Jul 19 at 08:55am CDT

ClaimsBridge services were impacted by the global outage caused by CrowdStrike this morning.